Disk Space Errors on Server prevent Index Processing

Symptoms

Processing of an index fails and out of disk space errors are reported in the Skimmer, Analysis, Scheduler or Application Overview logs.

Cause

  1. During analysis, files are temporarily retrieved to a local cache folder so they can be efficiently processed. By default the cache folder is located in 'Program Files > Active Navigation > Discovery Center > FileCache'. If there is insufficient disk space available in that location, Active Navigation will be unable to retrieve files for analysis and will report errors.

  2. Similarly, the Scheduler is responsible for Classification which involves the maintenance of a search index to support processing of classification rules. There must be sufficient space available to support management of this index. By default the search data folder is located in 'Program Files > Active Navigation > Discovery Center > SearchData'

  3. Finally the generation of logs for Skim, Analysis, and Scheduler processes may impact on the available disk space. By default the logs folder is located in 'Program Files > Active Navigation > Discovery Center > Logs'

Resolution

Increasing the amount of available storage to the system will typically correct the issues experienced with disk space errors in Discovery Center.

If more disk space is not an option, you can migrate these folders to a new location with more storage by following the steps in the related article: Change Locations for the Search Index, Analysis Cache, and Log Files

Additionally, clearing out old logs from the 'Program Files > Active Navigation > Discovery Center > Logs' path can reduce the size on disk, though this is a manual cleanup which can be performed by your server administrator.

Finally, if the increasing storage capacity and migrating the files to a larger disk are not an option, you can clean up the Search data folder contents by deleting the index.data folder within.

Do Not attempt to remove the files within the index.data folder. Delete the index.data folder as a whole.

Be sure to only remove this folder when there are no other processes running in Discovery Center and be sure to understand that deleting this folder will cause the Workbench Search results to be empty until index re-classification occurs.