Diagnosing SharePoint Access Issues

This article applies to instances of SharePoint On Premise, or O365 where using Discovery Center 4.13 or older. If you are using SharePoint O365 with Discovery Center 4.14 or greater, please read the article Here.

When trying to index a SharePoint location the skim process can fail with the location indicated as "Not Found", or terminates prematurely with incomplete results.

Cause

An error of this type normally indicates that the scheduler service account, or the credential specified for the location being indexed, does not have permission to access the location or the SharePoint repository is not accepting web service requests consistently.

Resolution

Permissions Required

The first step in investigating any SharePoint indexing issue is to confirm that the account in use has access to the location. 

In almost every case, problems with access to SharePoint result from the correct permissions not being in place so the first step is to review the specific access rights that have been granted to the account being used. If a review of index exceptions, scheduler log, skimmer log, or analysis log show clearly indicated "Unauthorized" error then this will typically be due to the required permissions not being present at some part of the SharePoint system.

The 2 key factors are that the correct rights are granted to allow web services to be used, and that these rights are available at all levels defined in the SharePoint URL being indexed. Refer to the article Setting Up SharePoint Permissions to understand how to correctly configure SharePoint permissions.

Other Factors

If you believe that all permissions are correct, or if the index process fails without indicating an "Unauthorized" error then there may be an aspect of your SharePoint configuration or SharePoint deployment architecture that is preventing consistent use of web services.

The Active Navigation Discovery Center skim and analysis processes will present an atypical request pattern to the SharePoint server and this may lead to issues that would not be encountered during normal user access using the same credentials.

The following items are some of the factors that you should consider when attempting to diagnose unexpected skim or analysis errors:

  • The SharePoint List View threshold is designed to prevent unexpected loads on the SharePoint server. If your site includes large lists it is possible we will exceed the list view threshold when attempting to complete a skim. In this case you will need to consider changing the threshold, or performing the skim using an administrative account that has access to a higher threshold value
  • SharePoint offers HTTP request throttling capabilities; if these are configured on your site they may be activated by high request rates resulting from skim and analysis via the Active Navigation Discovery Center.
  • We have seen a situation with customers where a load balancing front end led to premature termination of the skim process with aborted web service requests to the SharePoint server. If your architecture contains such elements and you experience errors with your index processing or performance issues then you should attempt to route around this component to see if that improves system behavior.
  • Hybrid authentication approaches using ADFS are supported for on premise and Office 365 sharepoint sites; third party authentication modules such as SecureAuth are not currently supported.
  • Multi-factor authentication can be bypassed by use of a Microsoft App Password. More information can be found below:
    Using Microsoft Office 365 Multi-Factor Authentication with Discovery Center

If the suggestions above do not help resolve your problem, please submit a support request outlining the investigations you have carried out and including your Active Navigation and SharePoint log files for the relevant time period.

 Applies to

Active Navigation Discovery Center 4.x